You are on page 1of 5

BUILDING 1

hostname Site-1
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 4
password cisco
login
service password-encryption
banner motd #message-of-the-day#
interface Serial0/0/0
bandwidth 128
ip address 192.168.10.105 255.255.255.252
description Police and Central
clock rate 128000
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 s0/0/0
interface s0/0/0
bandwidth 128
ip ospf cost 7500
ip dhcp excluded-address 192.168.45.1 192.168.45.20
ip dhcp excluded-address 192.168.47.1 192.168.47.20
ip dhcp pool VLAN45
network 192.168.45.0 255.255.255.0
default-router 192.168.45.1
dns-server 192.168.18.100
ip dhcp pool VLAN47
network 192.168.47.0 255.255.255.0
default-router 192.168.47.1
dns-server 192.168.18.100
exit
interface g0/0
no sh
interface g0/0.45
encapsulation dot1Q 45
ip address 192.168.45.1 255.255.255.0
interface g0/0.47
encapsulation dot1Q 47
ip address 192.168.47.1 255.255.255.0
interface g0/0.101
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0
router ospf 10

router-id 1.1.1.1
network 192.168.10.104 0.0.0.3 area 0
network 192.168.45.0 0.0.0.255 area 0
network 192.168.47.0 0.0.0.255 area 0
network 192.168.101.0 0.0.0.255 area 0
passive-interface g0/0.45
passive-interface g0/0.47
passive-interface g0/0.101
---------------------------MAIN
hostname HQ
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 4
password cisco
login
service password-encryption
banner motd #message-of-the-day#
interface Serial0/0/0
bandwidth 128
ip address 192.168.10.106 255.255.255.252
no shutdown
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.114 255.255.255.252
clock rate 128000
no shutdown
interface g0/0
ip address 192.168.18.41 255.255.255.248
no shutdown
interface Serial0/1/0
ip address 198.51.100.1 255.255.255.240
no shutdown
ip access-group 101 in
ip nat outside
access-list 1 permit 192.168.45.0 0.0.0.255
access-list 1 permit 192.168.47.0 0.0.0.255
access-list 1 permit 192.168.200.0 0.0.3.255
ip access-list standard MANAGE
permit host 203.0.113.18
access-list 101 permit ip host 203.0.113.18 any
access-list 101 permit tcp any host 198.51.100.14 eq www
access-list 101 permit tcp any any established
access-list 101 deny ip any any
!
line vty 0 4
access-class MANAGE in
password cisco
login
line vty 5 15
access-class MANAGE in

password cisco
login
exit
ip route 0.0.0.0 0.0.0.0 s0/1/0
ip route 192.168.200.0 255.255.252.0 s0/0/1
router ospf 10
router-id 2.2.2.2
network 192.168.10.104 0.0.0.3 area 0
network 192.168.10.112 0.0.0.3 area 0
network 192.168.18.40 0.0.0.7 area 0
passive-interface g0/0
interface s0/0/0
bandwidth 128
ip ospf cost 7500
interface s0/0/1
bandwidth 128
exit
ip nat inside source static 192.168.18.46 198.51.100.14
interface g0/0
ip nat inside
interface s0/1/0
ip nat outside
ip nat pool INTERNET 198.51.100.3 198.51.100.13 netmask 255.255.255.240
ip nat inside source list 1 pool INTERNET
ip nat inside source static 192.168.18.46 198.51.100.14
ip access-list standard 1
permit 192.168.45.0 0.0.0.255
permit 192.168.47.0 0.0.0.255
permit 192.168.200.0 0.0.3.255
---------------------------building 2
hostname Site-2
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 4
password cisco
login
service password-encryption
banner motd #message-of-the-day#
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.113 255.255.255.252
no shutdown
exit

ip route 0.0.0.0 0.0.0.0 s0/0/1


ip route 192.168.200.0 255.255.252.0 s0/0/0
router ospf 10
router-id 3.3.3.3
network 192.168.10.112 0.0.0.3 area 0
interface s0/0/1
bandwidth 128
----------------------sw1
hostname Site1-SW1
vlan 45
name finance
vlan 47
name sale
vlan 101
name netadmin
exit
int g0/1
switchport mode trunk
no shutdown
exit
int g0/2
switchport mode trunk
no shutdown
exit
int fa0/10
switchport mode access
switchport access vlan 45
no shut
exit
int fa0/15
switchport mode access
switchport access vlan 47
no shut
exit
ip default-gateway 192.168.101.1
interface vlan 101
ip address 192.168.101.2 255.255.255.0
int range fa0/1-9, fa0/11-14, fa0/16-24
switchport mode access
shutdown
-------------------------------sw2

hostname Site2-SW2
vlan 45
name finance
vlan 47
name sale
vlan 101
name netadmin
int g0/1
switchport mode trunk
no shutdown
int fa0/3
switchport mode access
switchport access vlan 45
no shut
exit
int fa0/21
switchport mode access
switchport access vlan 47
no shut
exit
ip default-gateway 192.168.101.1
interface vlan 101
ip address 192.168.101.3 255.255.255.0
int range fa0/1-2, fa0/4-20, fa0/22-24
switchport mode access
shutdown

You might also like