You are on page 1of 2

Una alternativa a las barras de datos

En esta ocasin te mostrar un uso interesante de la funcin REPETIR y cmo podemos


utilizarla como una alternativa al uso de los grficos de barras en Excel. Cuando ests
desarrollando un tablero de mando, tambin conocido como dashboard, el utilizar
grficas dentro de celdas puede ser de gran ayuda.
Podemos mejorar la visualizacin de nuestros datos y ayudar en la interpretacin de la
informacin si utilizamos la funcin REPETIR para crear minigrficos de barras en
Excel que se desplegarn dentro de una celda.

Minigrfico de barras con la funcin REPETIR

La funcin REPETIR (REPT en ingls) permite repetir un carcter, o un texto, un


nmero determinado de veces. Por ejemplo, la siguiente frmula mostrar XXXXX:
=REPETIR("X",5)

Para obtener los grficos dentro de celdas, tal como se observa en la imagen anterior, he
aplicado un tipo de fuente Arial tamao 8 para todas las celdas de la columna C. Ahora
bien, la frmula que introduciremos en dicha columna deber repetir el carcter |
tantas veces como est indicado en la columna B. Por ejemplo, la frmula de la celda
C2 ser la siguiente:
=REPETIR("|",B2) & " " & B2

En base al nmero de la celda B2 ser la cantidad de veces que se repetir el carcter |


y al final de la cadena de texto se concatenar el mismo nmero de la columna B para
ser desplegado junto a las barras.

Otro ejemplo de minigrfico de barras

Existe un gran nmero de aplicaciones diferentes para esta tcnica. Por ejemplo, para
graficar valores positivos o negativos podemos crear los minigrficos en dos columnas
diferentes:

Para este ejemplo he utilizado la funcin SI que nos ayudar a saber si el valor de la
columna B es positivo o negativo. En nuestro ejemplo, la columna C mostrar el
minigrfico para los valores negativos as que he utilizado una fuente de color rojo para
todas las celdas de la columna y adems he aplicado una alineacin a la derecha. La
frmula para la celda C2 es la siguiente:
=SI(B2<0,REPETIR("|",-B2),"")

La condicin B2<0 solo se cumplir cuando el valor de la celda B2 sea negativo en


cuyo caso se ejecutar la funcin REPETIR la cual nos devolver el minigrfico.
Observa que el segundo argumento de la funcin REPETIR tiene un signo negativo (-)
para convertir en positivo el valor de la celda B2 y as evitar un error.
Ahora observa con detenimiento la frmula para la celda D2. La condicin de la funcin
SI hace que solamente se muestre el minigrfico para los valores positivos:
=SI(B2>0,REPETIR("|",B2),"")

En este caso el segundo argumento de la funcin REPETIR ya no tiene el signo


negativo porque, gracias a la condicin de la funcin SI, solamente se recibirn valores
positivos. Ya que en nuestro ejemplo la celda B2 tiene un valor negativo, la nica celda
que mostrar el minigrfico ser la celda C2 y la celda D2 tendr una cadena de texto
vaca. Al copiar las frmulas hacia abajo obtendremos los minigrficos
correspondientes para todas las filas.
Seguramente encontrars alguna manera til de utilizar esta tcnica mientras diseas tus
tableros de control en Excel.