You are on page 1of 7

!

This configuration was tested on a Cisco 1760 series router w/ 128MB


! IPVOICE IOS version 12.4(15)T7 - c1700-ipvoicek9-mz.124-15.T7.bin
!
! Network config details:
! F0/0 interface is DHCP to cable modem provider
! 4-port FE WIC card installed and connection to an internal router
! via 10.1.53.0/24 network (VLAN 53)
! SIP devices are off of the internal router on 10.1.58.0/24
! device could be directly attached, but see notes below
! on pool configuration where MAC needs to be specified
!
! TIPS:
! 1) Do a search and replace for XXX with your local area code
! 2) Do a search and replace for YYYYYYYYYYY with your callcentric
! phone number. Should be 1777------- where '-' are digits.
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname liberty-border
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$jpup$2ayIMPJWb7oC0bw/hVWVc.
!
no aaa new-model
clock timezone PDT -8
clock summer-time PDT recurring
ip cef
!
!
no ip dhcp use vrf connected
! ***THIS DHCP POOL IS FOR DIRECTLY ATTACHED DEVICES
ip dhcp excluded-address 10.1.53.1 10.1.53.99
ip dhcp excluded-address 10.1.53.120 10.1.53.254
!
ip dhcp pool border-pool
network 10.1.53.0 255.255.255.0
default-router 10.1.53.1
domain-name home.your-domain.com
dns-server 4.2.2.2
!
!
ip domain name router.home.your-domain.com
ip name-server 4.2.2.2
multilink bundle-name authenticated
!
!
!
voice service voip
! ***IF YOU DON'T HAVE THIS NEXT LINE YOUR EXTENSIONS WILL
! NOT BE ABLE TO CALL EACH OTHER. IF YOU ARE USING
! SCCP DEVICES YOU NEED TO ADD MORE ALLOW-CONN STATEMENTS
allow-connections sip to sip
sip
registrar server expires max 36000 min 600
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
!
!
!
!
!
!
!
voice register global
mode cme
source-address 10.1.53.1 port 5060
max-dn 25
max-pool 24
hold-alert
tftp-path flash:
create profile sync 0001231562026553
!
voice register dn 1
number 101
call-forward b2bua noan 100 timeout 10
name Shawn
no-reg
label Shawn-101
!
voice register dn 2
number 102
call-forward b2bua noan 100 timeout 10
name Joy
no-reg
label Joy-102
!
voice register dn 4
number 104
call-forward b2bua noan 100 timeout 10
name LinksyPAP2T
no-reg
label Analog
!
voice register pool 1
! ********************************************************
! this MAC would normally be the MAC of the device, but I have the
! devices behind another internal router. Same for other pools.
! ********************************************************
id mac 000D.ED64.0ED0
number 1 dn 1
dtmf-relay rtp-nte sip-notify
username 101 password 101
codec g711ulaw
!
voice register pool 2
id mac 000D.ED64.0ED0
number 1 dn 2
dtmf-relay rtp-nte sip-notify
username 102 password 102
codec g711ulaw
!
voice register pool 4
id mac 000D.ED64.0ED0
number 1 dn 4
dtmf-relay rtp-nte
username 104 password 104
codec g711ulaw
!
!
! ***TRANSLATES AN EXTENSION TYPING 9911 -> 911, ETC.
voice translation-rule 1
rule 1 /9911/ /911/
rule 2 /9411/ /411/
!
! ***TRANSLATES AN EXTENSION TYPING XXX+local_number
! TO A FORMAT CALLCENTRIC LIKES. IF YOU STILL SEE
! 3-X'S BELOW YOU SHOULD SEE TIPS AT TOP OF DOC
voice translation-rule 2
rule 1 /9XXX+/ /1XXX/
!
! ***TRANSLATES AN EXTENSION TYPING 9+local_number
! TO A FORMAT CALLCENTRIC LIKES.
voice translation-rule 3
rule 1 /9+/ /1XXX/
!
! ***TRANSLATES AN EXTENSION TYPING 9+1+long_dist_number
voice translation-rule 4
rule 1 /91+/ /1/
!
! ***USED FOR INBOUND DIALING RULE. THIS IS THE NUMBER
! ASSOCIATED WITH YOUR CALLCENTRIC ACCOUNT THAT COMES
! DOWN THE SIP TRUNK. I AM TRANSLATING THIS TO EXT. 101
voice translation-rule 5
rule 1 /YYYYYYYYYYY/ /101/
!
! ***USED FOR TRANSLATE A LOCAL 1xx EXTENSION TO YOUR
! CALLCENTRIC.COM PHONE NUMBER
voice translation-rule 7
rule 1 /1../ /YYYYYYYYYYY/
!
!
! ***THESE MAKE THE STATEMENTS ABOVE WORK FOR THE PATTERNS
! SPECIFIED IN THE 'DIAL-PEER' SECTION BELOW
voice translation-profile Incoming
translate called 5
!
voice translation-profile Local10
translate calling 7
translate called 2
!
voice translation-profile Local7
translate calling 7
translate called 3
!
voice translation-profile LongDistance
translate calling 7
translate called 4
!
voice translation-profile Services
translate calling 7
translate called 1
!
!
!
interface ATM0/0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0/0
description Native Cable modem in
ip address dhcp
ip nat outside
ip virtual-reassembly
speed auto
!
interface FastEthernet1/1
description Border Network Interface
switchport access vlan 53
!
interface FastEthernet1/2
switchport access vlan 55
spanning-tree portfast
!
interface FastEthernet1/3
switchport access vlan 53
spanning-tree portfast
!
interface FastEthernet1/4
switchport access vlan 53
duplex full
speed 100
!
interface Vlan1
no ip address
!
interface Vlan52
description Test VLAN
ip address 10.1.52.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan53
description Border Network
ip address 10.1.53.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan55
description DMZ Network - temp
ip address 10.1.55.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
! ***THESE ARE MY INSIDE NETWORKS BEHIND INSIDE ROUTER - 10.1.53.2
ip route 10.1.54.0 255.255.255.0 10.1.53.2
ip route 10.1.56.0 255.255.255.0 10.1.53.2
ip route 10.1.57.0 255.255.255.0 10.1.53.2
ip route 10.1.58.0 255.255.255.0 10.1.53.2
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip http path flash:
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source list 151 interface FastEthernet0/0 overload
ip nat inside source static udp 10.1.55.3 20 interface FastEthernet0/0 20
ip nat inside source static tcp 10.1.55.3 20 interface FastEthernet0/0 20
ip nat inside source static udp 10.1.55.3 21 interface FastEthernet0/0 21
ip nat inside source static tcp 10.1.55.3 21 interface FastEthernet0/0 21
ip nat inside source static tcp 10.1.55.3 443 interface FastEthernet0/0 443
ip nat inside source static udp 10.1.55.3 443 interface FastEthernet0/0 443
ip nat inside source static udp 10.1.55.3 80 interface FastEthernet0/0 80
ip nat inside source static tcp 10.1.55.3 80 interface FastEthernet0/0 80
ip nat inside source static udp 10.1.54.4 3389 interface FastEthernet0/0 3389
ip nat inside source static tcp 10.1.54.4 3389 interface FastEthernet0/0 3389
!
ip access-list extended inbound_f0
permit tcp any any established log
deny tcp any any log
deny icmp any any redirect log
deny ip 172.16.0.0 0.15.255.255 any log
deny ip 192.168.0.0 0.0.255.255 any log
deny ip 127.0.0.0 0.255.255.255 any log
deny ip 224.0.0.0 7.255.255.255 any log
deny ip host 0.0.0.0 any log
deny icmp any any echo log
deny udp any any eq snmp log
deny udp any any eq 135 log
deny udp any any eq netbios-ns log
deny udp any any eq netbios-dgm log
deny udp any any eq netbios-ss log
permit ip any any log
!
access-list 1 permit 10.1.53.0 0.0.0.255
access-list 1 permit 10.1.56.0 0.0.0.255
access-list 1 permit 10.1.54.0 0.0.0.255
!
control-plane
!
!
!
!
!
!
! **********************
! ***DIAL-PEER SECION***
! **********************
dial-peer voice 10 voip
translation-profile outgoing Services
destination-pattern 9[49]11
session protocol sipv2
session target dns:callcentric.com
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 11 voip
translation-profile outgoing Local10
destination-pattern 9XXX[2-9]......
session protocol sipv2
session target dns:callcentric.com
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 12 voip
translation-profile outgoing Local7
destination-pattern 9[2-9]......
session protocol sipv2
session target dns:callcentric.com
incoming called-number .
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 13 voip
translation-profile outgoing LongDistance
destination-pattern 91[2-9]..[2-9]......
session protocol sipv2
session target dns:callcentric.com
dtmf-relay rtp-nte
codec g711ulaw
!
! ***VOICEMAIL ISN'T WORKING YET; HAVEN'T TRIED
dial-peer voice 14 voip
description Voicemail
destination-pattern *123
session protocol sipv2
session target dns:callcentric.com
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 1 voip
description Incoming
translation-profile incoming Incoming
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target dns:callcentric.com
incoming called-number YYYYYYYYYYY
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
sip-ua
! ***YOUR CALLCENTRIC.COM USERNAME AND PASSWORD WOULD BE HERE
credentials username YYYYYYYYYYY password BLAHBLAHBLAH realm callcentric.com
authentication username YYYYYYYYYYY password 7 BLAHBLAHBLAH
no remote-party-id
mwi-server dns:callcentric.com expires 300 port 5060 transport udp
registrar dns:callcentric.com expires 300
sip-server dns:callcentric.com:5060
host-registrar
!
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
ntp clock-period 17208124
ntp server 129.6.15.28 source FastEthernet0/0
end

You might also like