You are on page 1of 15

LAB-01: BASIC ROUTER CONFIGURATION

1. In this lab, you will get practice with basic configuration and show commands on the
Cisco router.

2. Select Router1 from the tool bar. Press enter to get to the user prompt

Router>

3. The greater-than symbol ( >) in the prompt indicates you are in user mode. Type ? to
see a list of commands that can be entered in user mode.

Router> ?

4. Type enable to get into privileged mode. The pound sign (#) indicates you are now in
privileged mode.

Router> enable
Router#

5. Type ? to see a list of commands that can be entered in privileged mode. Notice that
there are more commands available in privileged mode than are available in user
mode. Configure and reload are two such commands that can only be issued in
privileged mode.

Router# ?

6. Exit privileged mode by typing disable.

Router# disable
Router>

7. Re-enter privileged mode and type configure terminal to get into configuration mode

Router> enable
Router# configure terminal
Router(config)#

8. Configure a hostname of ‘router1’ (without the quote marks). Notice how the prompt
changes.
Router(config)# hostname router1
router1(config)#

9. In global configuration mode on router1, type enable ?. This will show valid
parameters that can be entered with the enable command.

Configure an enable password of ‘ccnalab’ that will not be encrypted when viewing
the router configuration file and an enable password of ’cisco’ that will be encrypted.

a. Question: when both encrypted and unencrypted enable passwords are


configured,
which one is used?

router1(config)# enable ?
router1(config)# enable password ccnalab
router1(config)# enable secret cisco

10. Configure an IP address for the Ethernet0 interface on router1 (refer to the table on
page 6 for all IP addresses and masks).

Activate the interface – it is currently in ‘shutdown’ mode. You should see a message
that the interface has now come up.

Practice using the tab key – type int and then the tab key (no spaces). You should
see the
word interface spelled out.

router1(config)# int
router1(config)# interface ethernet0
router1(config-if)# ip address 160.10.1.1 255.255.255.0
router1(config-if)# no shutdown

11. Configure an IP address for router1’s Serial0 interface (refer to the table for IP
addresses and masks) and activate the interface.
Practice using abbreviated commands for both interface serial0 and no shutdown.

router1(config-if)# int s0
router1(config-if)# ip address 175.10.1.1 255.255.255.0
router1(config-if)# no shut

12. Exit configuration mode by keying ctrl-z . This will bring you back to the privileged
mode prompt. You could also accomplish the same thing by keying exit twice. The
exit command moves you back one level (from interface-configuration mode - global
configuration mode - privileged mode prompt).

router1(config-if)# ctrl-z
router1#

13. Type logout to exit the command line interface


router1# logout

14. Press the enter key to get back into the user mode prompt and then type enable to
get into privileged mode. You will be prompted for the enable secret password ‘cisco’
which you previously configured.

router1> enable

password: cisco

router1#

15. Display a summary of all interfaces by typing:


router1# show ip interface brief

16. Display detailed information on each interface by typing:


router1# show interfaces

17. Display the active configuration in DRAM by typing:


router1# show running-config

18. Display the saved configuration in NVRAM by typing show startup-config.


a. Question: does anything exist in NVRAM? If not, why not?
router1# show startup-config

19. Save the running (active) configuration to NVRAM by typing:


router1# copy running-config startup-config

20. Now display the contents of NVRAM again. This time, you should see the active
configuration saved in NVRAM.

router1# show startup-config

21. Issue the show version command and answer these questions:
a. Question: What IOS release is running on router1?
b. Question: What are the contents of the configuration register?
router1# show version

22. Issue the command to show which Layer 3 protocols are currently running on the
router.
a. Question: which protocols are currently running on the router?
router1# show protocols
23. Select router2 from the toolbar on top. Press enter and get into user mode. From
there go into privileged mode.

Router> enable

Router# configure terminal

Router(config)#

24. Configure a hostname of ‘router2’ and configure an enable secret password of ‘cisco’
for router2.

Router(config)# hostname router2


router2(config)# enable secret cisco

25. Configure an IP address for Fast Ethernet 0/0 on router2 and activate the interface
(see the diagram above for IP addresses and masks). Router2 is 2600 modular
router and must be configured using slot/port notation.

router2(config)# interface Fa 0/0

router2(config-if)# ip address 160.10.1.2 255.255.255.0

router2(config-if)# no shut

26. Display the summary status of all interfaces. Remember to get out of configuration
mode first before issuing any show commands.
a. Question: what status should interface Fa 0/0 show if it is fully activated?
b. Question: what status would Fa 0/0 show if it was in ‘shutdown’ mode?
router2(config-if)# ctrl-z
router2# show ip interface brief

27. Try to ping router1’s Ethernet address (160.10.1.1) from router2.


a. Question: Were you successful? If not, what commands should you use for
troubleshooting?
router2# ping 160.10.1.1
LAB-02: ADVANCED ROUTER CONFIGURATION

1. In this lab you will practice using some advanced configuration and show commands
on the Cisco router. Please remember your lab 1 commands needed to switch
between Router modes (i.e. exit, end, disable)

2. On router1, configure a console password of ‘boson’. The console user must enter
this password before gaining access to the user mode prompt.

router1(config)# line console 0

router1(config-line)# login

router1(config-line)# password boson

3. Configure a banner that says” Welcome to Router1 - Authorized Users Only”.

router1(config)# banner motd #

Welcome to Router1 - Authorized Users Only #

4. Test the banner and console password by logging out of the router and logging back
in. Get into enable mode after successfully logging into the console.

router1# logout

enter

password: boson

router1> enable

password: cisco

router1#
5. Configure a password of ‘cisco’ on router2 that will enable remote users to Telnet into
it:

router2(config)# line vty 0 4

router2(config-line)# login

router2(config-line)# password cisco

6. On router1, associate a name of ‘router2’ with the remote IP address 160.10.1.2.


This will allow you to ping router2’s name rather than having to remember its IP
address. router1(config)# ip host router2 160.10.1.2

7. Verify that the name is in router1’s host table with the show hosts command.
router1# show hosts

8. Ping ‘router2’ and verify that the pings succeed.


router1# ping router2

9. Display the contents of flash memory on router2.


a. Question: what is the name of the IOS image in flash and how large is it?
router2# show flash

10. Display the history table on router1. This shows the last 10 commands that were
entered on the router. You can recall commands by entering CTRL-P or by hitting the
up arrow key.

router1# show history

router1# ctrl-p (to see previously entered commands)

11. On router1, do a show interfaces on Serial 0. Note on the third line of the output that
the bandwidth is assumed to be 1544kb. This is because the router assumes all
serial links are T1’s unless you configure otherwise. Configure router1’s S0 link to
have a bandwidth of 64kb and then reenter the show interfaces command.

router1# show interfaces serial 0

router1# configure terminal

router1(config)# interface serial 0

router1(config-if)# bandwidth 64

router1(config-if)# clock rate 64000

router1(config-if)# ctrl-z
router1# show interfaces serial 0

12. On router1, add a description to interface Serial 0 that says “Serial Link to Router3”.
This description will appear whenever you issue a show interfaces command for
Serial 0.

router1(config)# interface serial 0


router1(config-if)# description Serial Link to Router3
router1(config-if)# exit
router1(config)# exit
router1# show interfaces serial 0

13. Configure router3 and router4:

• configure hostnames

• configure an enable secret password of ‘cisco’

• assign IP addresses and subnet masks to serial & Ethernet interfaces (see table on
page 6)

• Remember to set the clock rate on the Router 3 Serial 1 interface.

• activate serial and Ethernet interfaces

• verify router3 can ping router1

• verify router3 can ping router4

• save the configurations to NVRAM


LAB-03: IP ADDRESSING

You have just been asked to build a lab network to test new configurations that will be rolled
out to your production network. Host A(on the left) should be setup with an IP address of
192.168.101.2/24 and a default gateway of 192.168.101.1. Host B (in the right) should be
setup with an IP address of 192.168.100.2/24 and default gateway of 192.168.100.1. The
Ethernet interface of Router 1(on the left) should use an IP address of 192.168.101.1/24 and
the serial interface of Router 1 should use IP address of 192.168.1.1/24. The Ethernet
interface of Router 2(on the right) should use an IP address of 192.168.100.1/24 and the
serial interface of Router 2 should use IP address of 192.168.1.2/24. You have DCE cable
connected to Router 1. The serial link should have speed of 64K. Configure the devices with
hostname and make sure that the can ping any device that is directly connected. When you
are finished with the lab select the File->Save Network Configuration for use in the future
labs.

R1:
Hostname router1
!
Interface Ethernet0
Ip address 192.168.101.1 255.255.255.0
Clock rate 64000
No shut

R2:
Hostname router2
!
Interface Ethernet0
Ip address 192.168.100.1 255.255.255.0
No shut
!
Interface serial0
Ip address 192.168.1.2 255.255.255.0
No shut

HOST A:
Ipconfig/IP 192.168.101.2 255.255.255.0
Ipconfig/DG 192.168.101.1

HOST B:
Ipconfig/IP 192.168.100.2 255.255.255.0
Ipconfig/DG 192.168.100.1
OUTPUT:
LAB-04: STATIC ROUTES

You are building a lab network to test new configurations that will be rolled out to your
production network. Host A(on the left) should be setup with an IP address of
192.168.101.2/24 and a default gateway of 192.168.101.1. Host B (in the right) should be
setup with an IP address of 192.168.100.2/24 and default gateway of 192.168.100.1. The
Ethernet interface of Router 1(on the left) should use an IP address of 192.168.101.1/24 and
the serial interface of Router 1 should use IP address of 192.168.1.1/24. The Ethernet
interface of Router 2(on the right) should use an IP address of 192.168.100.1/24 and the
serial interface of Router 2 should use IP address of 192.168.1.2/24. You have DCE cable
connected to Router 1. The serial link should have speed of 64K. Configure the routers with
static routes so that all devices can ping any other device.

R1:
Hostname router1
!
Interface Ethernet0
Ip address 192.168.101.1 255.255.255.0
No shut
!
Interface serial0
Ip address 192.168.1.1 255.255.255.0
Clock rate 64000
No shut
!
Ip route 192.168.100.0 255.255.255.0 192.168.1.2

R2:
Hostname router2
!
Interface Ethernet0
Ip address 192.168.100.1 255.255.255.0
No shut
!
Interface serial0
Ip address 192.168.1.2 255.255.255.0
No shut
!
Ip route 192.168.101.0 255.255.255.0 192.168.1.1

HOST A:
Ipconfig/IP 192.168.101.2 255.255.255.0
Ipconfig/DG 192.168.101.1

HOST B:
Ipconfig/IP 192.168.100.2 255.255.255.0
Ipconfig/DG 192.168.100.1

OUTPUT:
LAB-05: DEFAULT ROUTES
You have the job to setup a small customer network. Host A(on the left) should be setup with
an IP address of 192.168.101.2/24 and a default gateway of 192.168.101.1. Host B (in the
right) should be setup with an IP address of 192.168.100.2/24 and default gateway of
192.168.100.1. The Ethernet interface of Router 1(on the left) should use an IP address of
192.168.101.1/24 and the serial interface of Router 1 should use IP address of
192.168.1.1/24. The Ethernet interface of Router 2(on the right) should use an IP address of
192.168.100.1/24 and the serial interface of Router 2 should use IP address of
192.168.1.2/24. You have DCE cable connected to Router 1. The serial link should have
speed of 64K. Configure the routers with default routes so that all devices can ping any other
device.

R1:
Hostname router1
!
Interface Ethernet0
Ip address 192.168.101.1 255.255.255.0
No shut
!
Interface serial0
Ip address 192.168.1.1 255.255.255.0
Clock rate 64000
No shut
!
Ip route 0.0.0.0 0.0.0.0 192.168.1.2

R2:
Hostname router2
!
Interface Ethernet0
Ip address 192.168.100.1 255.255.255.0
No shut
!
Interface serial0
Ip address 192.168.1.2 255.255.255.0
No shut
!
Ip route 0.0.0.0 0.0.0.0 192.168.1.1

HOST A:
Ipconfig/IP 192.168.101.2 255.255.255.0
Ipconfig/DG 192.168.101.1

HOST B:
Ipconfig/IP 192.168.100.2 255.255.255.0
Ipconfig/DG 192.168.100.1

OUTPUT:

You might also like